DO NOT REPLY [Bug 34847] New: - incorrect image rendering

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

DO NOT REPLY [Bug 34847] New: - incorrect image rendering

Bugzilla from bugzilla@apache.org
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG?
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34847>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND?
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34847

           Summary: incorrect image rendering
           Product: Batik
           Version: 1.5
          Platform: Other
        OS/Version: Windows 2000
            Status: NEW
          Severity: major
          Priority: P2
         Component: SVG Rasterizer
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]


Using the sample file copied below:
The file has a viewbox of width 352 and height 416. The svg elements width and
height is set to 100%. So (if my understanding is correct) the image should
scale itself to any dimension.

But when i try to rasterize it by supplying width value as 352 and height value
as 416 -- i get an image (of size 352 and 416) in which the svg content does not
occupy the entire area of the canvas --the image occupies 310x366 pixels on the
top left and the rest (in right and bottom of the image) is shown transparent.

The problem does not happen if the image is rastererized to a different size say
352x500.

================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1 Tiny//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11-tiny.dtd">
<svg baseProfile="tiny" height="100%" preserveAspectRatio="xMidYMid meet"
version="1.0" viewBox="0 0 352 416" width="100%"
xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"
zoomAndPan="magnify">
<switch>
<foreignObject content="structured text" height="1"
requiredExtensions="http://ns.adobe.com/AdobeIllustrator/10.0/" width="1" x="0"
y="0"/>
<g>
<g>
<radialGradient cx="176" cy="208" fx="176" fy="208"
gradientUnits="userSpaceOnUse" id="XMLID_1_" r="192.6655">
<stop offset="0" style="stop-color:#EFF60B"/>
<stop offset="1" style="stop-color:#EF0003"/>
</radialGradient>
<path d="M352,416H0V0h352V416z" fill="url(#XMLID_1_)"/>
</g>
</g>
</switch>
</svg>
================================================================

--
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]