[jira] [Created] (BATIK-1192) Multiple Maven artifact broken since 1.9

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (BATIK-1192) Multiple Maven artifact broken since 1.9

JIRA jira@apache.org
CAILLET Frederic created BATIK-1192:
---------------------------------------

             Summary: Multiple Maven artifact broken since 1.9
                 Key: BATIK-1192
                 URL: https://issues.apache.org/jira/browse/BATIK-1192
             Project: Batik
          Issue Type: Bug
    Affects Versions: 1.9
            Reporter: CAILLET Frederic
            Priority: Blocker


I've recently updated a project to use FOP 2.2 which depends on Batik 1.9.

Since this update, Maven fails to update the dependencies with the following error :
{quote} Failed to collect dependencies at org.apache.xmlgraphics:fop:jar:2.2 -> org.apache.xmlgraphics:batik-svg-dom:jar:1.9: Failed to read artifact descriptor for org.apache.xmlgraphics:batik-svg-dom:jar:1.9: Could not find artifact org.apache.xmlgraphics:batik:pom:1.9{quote}

It seems the POM of several Batik artifacts refers to a parent POM of Batik which does not exist in the maven repositories :
{quote}<parent>
 <groupId>org.apache.xmlgraphics</groupId>
 <artifactId>batik</artifactId>
 <version>1.9</version>
</parent>{quote}

The Batik artifacts currently referring to batik-1.9.pom are :
batik-awt-util-1.9.pom
batik-bridge-1.9.pom
batik-ext-1.9.pom
batik-extension-1.9.pom
batik-gvt-1.9.pom
batik-svg-dom-1.9.pom
batik-transcoder-1.9.pom

Thanks for your help.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]