[jira] [Resolved] (BATIK-1185) Maven batik-i18n artifact broken

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (BATIK-1185) Maven batik-i18n artifact broken

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/BATIK-1185?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

simon steiner resolved BATIK-1185.
----------------------------------
    Resolution: Fixed

> Maven batik-i18n artifact broken
> --------------------------------
>
>                 Key: BATIK-1185
>                 URL: https://issues.apache.org/jira/browse/BATIK-1185
>             Project: Batik
>          Issue Type: Bug
>    Affects Versions: 1.9
>            Reporter: Martin Wegner
>            Assignee: simon steiner
>            Priority: Blocker
>
> Since 1.9 I got *ClassNotFoundException: org.apache.batik.i18n.Localizable* from:
> {noformat}
> at org.apache.fop.image.loader.batik.BatikUtil.isBatikAvailable(BatikUtil.java:41)
> at org.apache.fop.image.loader.batik.ImageLoaderFactorySVG.isAvailable(ImageLoaderFactorySVG.java:56)
> at org.apache.xmlgraphics.image.loader.spi.ImageImplRegistry.registerLoaderFactory(ImageImplRegistry.java:182)
> at org.apache.xmlgraphics.image.loader.spi.ImageImplRegistry.discoverClasspathImplementations(ImageImplRegistry.java:111)
> at org.apache.xmlgraphics.image.loader.spi.ImageImplRegistry.<init>(ImageImplRegistry.java:79)
> at org.apache.xmlgraphics.image.loader.spi.ImageImplRegistry.<init>(ImageImplRegistry.java:87)
> at org.apache.xmlgraphics.image.loader.spi.ImageImplRegistry.<clinit>(ImageImplRegistry.java:71)
> at org.apache.xmlgraphics.image.loader.ImageManager.<init>(ImageManager.java:64)
> at org.apache.fop.apps.FopFactoryBuilder$FopFactoryConfigImpl.<init>(FopFactoryBuilder.java:381)
> at org.apache.fop.apps.FopFactoryBuilder.<init>(FopFactoryBuilder.java:90)
> at org.apache.fop.apps.FopConfParser.<init>(FopConfParser.java:155)
> at org.apache.fop.apps.FopConfParser.<init>(FopConfParser.java:74)
> {noformat}
> So I added the *batik-i18n* artifact as a runtime dependency. But this artifact is broken:
> {noformat}
> Failed to collect dependencies at org.apache.xmlgraphics:batik-i18n:jar:1.9: Failed to read artifact descriptor for org.apache.xmlgraphics:batik-i18n:jar:1.9: Failure to find org.apache.xmlgraphics:batik:pom:1.9
> {noformat}
> I think the reason is inside the batik-i18n POM:
> {noformat}
> <parent>
>   <groupId>org.apache.xmlgraphics</groupId>
>   <artifactId>batik</artifactId>
>   <version>1.9</version>
> </parent>
> {noformat}
> This parent does not exist.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]