[jira] [Resolved] (BATIK-1188) Failed to convert SVG to PNG using batik-rasterizer from maven repository

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (BATIK-1188) Failed to convert SVG to PNG using batik-rasterizer from maven repository

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/BATIK-1188?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

simon steiner resolved BATIK-1188.
----------------------------------
    Resolution: Not A Problem

> Failed to convert SVG to PNG using batik-rasterizer from maven repository
> -------------------------------------------------------------------------
>
>                 Key: BATIK-1188
>                 URL: https://issues.apache.org/jira/browse/BATIK-1188
>             Project: Batik
>          Issue Type: Bug
>            Reporter: Tuan Huynh
>
> Hi there,
> Thanks again for great libary. We've been trying to use batik-rasterizer-1.9.jar from Maven Repository but no luck so far,
> With this simple command: java -jar batik-rasterizer-1.9.jar -scriptSecurityOff ./tets.svg -d ./test.png, we're getting this error:
> About to transcode 1 SVG file(s)
> Converting tets.svg to ./test.png ... org.apache.batik.transcoder.TranscoderException: null
> Enclosed Exception:
> Could not write PNG file because no WriteAdapter is availble
> at org.apache.batik.transcoder.image.ImageTranscoder.transcode(ImageTranscoder.java:132)
> at org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(XMLAbstractTranscoder.java:142)
> at org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(SVGAbstractTranscoder.java:156)
> at org.apache.batik.apps.rasterizer.SVGConverter.transcode(SVGConverter.java:1001)
> at org.apache.batik.apps.rasterizer.SVGConverter.execute(SVGConverter.java:717)
> at org.apache.batik.apps.rasterizer.Main.execute(Main.java:938)
> at org.apache.batik.apps.rasterizer.Main.main(Main.java:992)
> ... error (SVGConverter.error.while.rasterizing.file)
> This also happens in 1.8 but can be solved by adding batik-codec 1.8 and xmlgraphics-commons 2.0, however, it's not the case in 1.9. In 1.7, adding batik-codec 1.7 is enough.
> Could you please give us a hand on this?
> Thanks and Regards,
> Tuan.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]